nodeJS

Error: /lib64/libc.so.6: version ‘GLIBC_2.14’ not found

Sometimes on your node.js project you have seen problems like “Error: /lib64/libc.so.6: version ‘GLIBC_2.14’ not found” by some npm modules.

Error: /lib64/libc.so.6: version ‘GLIBC_2.14’ not found

This error comes when the available version of glibc is not compatible by the node module.

So, if you still want to work with that module, you need to rebuild that module on your project.

To do this simply go to Github, Clone a repo for node module where its installed in project, may be in node_modules directory.

Inside the node_modules directory clone that repo:

Example- git clone https://github.com/node-xmpp/node-expat.git

Now go to the cloned module, cd node-expat

Then install all node module dependencies.
npm install

After installing it to a clean build for that module:
node-gyp rebuild

Voila! Use the module in your project now.

You Might Also Like